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Before You Begin

About This Book
This book describes the user interface and functions of the Log Flag Editor 
utility. This utility can be opened only from the Log Viewer, a part of the 
System Management Console suite of utilities. The remainder of this book is 
organized in the following fashion:

• Overview: contains introductory information about the Log Flag Editor, 
including general information about default log flags, custom log flags and 
how to use them.

• Using the Log Flag Editor: describes procedures for manipulating and 
creating log flags as a means to modify the kinds of messages logged to 
the Logger.

• Log Flag Editor User Interface: describes the windows, menus and dialog 
boxes associated with the Log Flag Editor utility.

• Index

You can view this document online or you can print it, in part or whole, by 
using the Adobe Acrobat Reader’s print facility.

Documentation Conventions
This documentation uses the following conventions:

Technical Support
Wonderware Technical Support offers a variety of support options to answer 
any questions on Wonderware products and their implementation.

Prior to contacting technical support, please refer to the relevant chapter(s) in 
your Log Flag Editor User’s Guide for a possible solution to any problem you 
may have with the Log Flag Editor. If you find it necessary to contact technical 
support for assistance, please have the following information available:

Convention Used for
Bold Menus, commands, buttons, icons, dialog boxes and 

dialog box options. 
Monospace Start menu selections, text you must type, and 

programming code.
Italic Options in text or programming code you must type.
Log Flag Editor User’s Guide



8 Before You Begin
• The type and version of the operating system you are using. For example, 
Microsoft Windows XP.

• The exact wording of the error messages encountered.

• Any relevant output listing from the Log Viewer or any other diagnostic 
applications.

• Details of the attempts you made to solve the problem(s) and your results.

• Details of how to recreate the problem.

• If known, the Wonderware Technical Support case number assigned to 
your problem (if this is an ongoing problem).
Log Flag Editor User’s Guide
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C H A P T E R  1

Overview

The Log Flag Editor is an ArchestrA™ utility you can use to selectively log 
messages from product components to the ArchestrA Logger. By switching on 
and off categories of messages (log flags), you can control the information 
logged. Message logging can be controlled on a global and component-specific 
basis.

Also, you can save specific log flag settings to a file and then share those 
settings with other users so that only certain types of data are logged on their 
computers.

Contents
• Log Flags Defined

• Components and Log Flags

• When to Use the Log Flag Editor

• Using the Log Flag Editor on Remote Nodes

Log Flags Defined
Log flags are message categories that can be switched on and off to control 
which messages are logged by the Logger.

Every message sent to the Logger by ArchestrA components is associated with 
a log flag. This association between message and log flag is assigned in the 
component by the developer of that component. Every message first must meet 
the current log flag settings before being logged.

When a log flag is switched on, messages of that log flag category are logged 
by the Logger. When it is switched off, they are not logged.

Note  Using log flags is not the same as using the filter function of the Log 
Viewer utility. With log flags, messages whose log flag has been turned off are 
not logged at all. With the Log Viewer filter, messages that are filtered are just 
hidden from view. See Log Viewer documentation for further information 
about filtering messages.

There are two main types of log flags:

• Default log flags: these apply to all ArchestrA-enabled components on 
your computer.
Log Flag Editor User’s Guide



10 Chapter 1
• Custom log flags: these apply to only one or perhaps a few ArchestA 
components on your computer.

Default Log Flags
All ArchestrA components use the default log flags. They are displayed first in 
the Log Flags View of the user interface and are shown in black text, followed 
by custom log flags (shown in blue text) in alphanumeric order. The default log 
flags include the following:

Default Log 
Flag Description
Error Use this log flag to log error messages, which indicate 

problems that should not occur. For instance, an error 
message might indicate that a file is not found in an 
expected location and the program cannot recover by 
creating the file.

Warning Use this log flag to log warning messages, which 
indicate that an unexpected event occurred but the 
program was able to recover.

Info Use this log flag to log informational messages, which 
indicate normal program events. These messages 
typically indicate the status of expected operations.

Trace Use this log flag to log generic trace messages, which 
indicate internal object states, variable values, GUIDs 
and other low level data.

Start-Stop Use this log flag to log messages when a component has 
been started or stopped.

Entry-Exit Use this log flag to log messages when particular 
functions have been entered and exited.

ThreadStart-Stop Use this log flag to log messages that indicate a thread 
has started or stopped.

SQL Use this log flag to log SQL related messages. Typically, 
these messages are used to show long SQL strings.

Connection Use this log flag to log messages from communication 
components that manage connections with clients or 
servers.

Ctor-Dtor Use this log flag to log constructor/destructor messages, 
which typically indicate object creation and deletion 
from memory.

RefCount Use this log flag to log object reference count messages 
from objects that manage their life span by counting their 
clients.
Log Flag Editor User’s Guide
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Custom Log Flags
Most ArchestrA components have unique messages that do not fit into a 
default log flag category. In those cases, the component developer assigns 
custom log flags to those messages.

Several components can share a custom log flag if they send similar messages 
that fit into that category and if they assign those messages to the custom log 
flag. Another component, though, cannot use a custom log flag if, during its 
development, it did not initially assign a message to that log flag.

The Log Flag Editor displays custom log flag names in blue text.

Components and Log Flags
The Log Flag Editor displays a list of all ArchestrA components installed on 
the target node. Selecting a component displays its log flags, including default 
and custom ones. Selecting the Global option displays all log flags for all 
ArchestrA components.

The component list in the Log Flag Editor is not dynamic. You must restart the 
utility to display a newly installed component, and you must use the Remove 
Component command to remove from the component list one that has been 
uninstalled from the selected node.

To enable a log flag, you must select its check box. To disable it, select the 
check box again. If you select Global in the component list and then enable a 
log flag, that log flag is automatically enabled for all components. If the check 
box for a log flag is colored gray, that log flag is enabled for at least one 
component but not globally.

Note  To begin logging messages associated with newly selected log flags, 
you must apply the new log flag settings. See the Apply command in the Menu 
Bar section of the Log Flag Editor User Interface chapter.

Use the Global option to control the messages for all ArchestrA components 
installed on the selected node. For instance, when Global is selected and the 
Trace log flag is enabled, all Trace messages for all ArchestrA components on 
the selected node are logged.

Use a specific component in the component list to control the messages just for 
that component. For instance, assume the Trace log flag for the Global option 
is enabled. If you then select a specific component and switch its Trace log 
flag off, the Logger stops logging Trace messages for that component while 
continuing to log them for all other components. The reverse is true if the 
Trace log flag for the Global option is switched off and the component-
specific Trace log flag is enabled. In this case, the Logger logs Trace 
messages only for that component.
Log Flag Editor User’s Guide
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When to Use the Log Flag Editor
The Log Flag Editor is primarily a troubleshooting tool. By default, most log 
flags are switched off because most potential messages are not required during 
normal operation of ArchestrA components. Also, switching on log flags 
(especially globally) can affect the selected node’s performance.

For instance, use the Log Flag Editor when a particular ArchestrA component 
begins logging error or warning messages. Select the malfunctioning 
component in the component list, and then switch on specific log flags. After 
applying the new log flag settings, new messages that appear in the Logger can 
help troubleshoot the component.

Using the Log Flag Editor on Remote Nodes
You can use the Log Flag Editor to edit log flags on remote nodes and, 
therefore, control which messages are logged on the remote Logger. Do this by, 
first, selecting the remote node in the Log Viewer and then starting the Log 
Flag Editor.

Note  See Log Viewer documentation for more information about adding 
remote nodes in the Console Tree, connecting to them, and starting the Log 
Flag Editor.

While the Log Flag Editor attempts to connect to the Logger of the selected 
node, a status dialog box is displayed. If any of the following scenarios occurs, 
the Log Flag Editor is not started:

• You cancel the connection attempt for a non-responsive node.

• If the Log Flag Editor is unable to connect with the remote node, a 
message is displayed.

• If logging is disabled on the selected node, a message is displayed.

Note  See Log Viewer documentation for more information about 
enabling/disabling logging on a node.

All functions described in the remainder of this documentation apply equally 
to local Loggers and those on remote nodes. For instance, if you open a log 
flag file (.aaLGF extension) and use the Apply command on the File menu, 
those settings are applied to the Logger on the node that is currently selected in 
the Log Viewer Console Tree.

For information about remote nodes and their effects on the Log Flag Editor 
user interface, see Remote Nodes and the Main Window.
Log Flag Editor User’s Guide
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C H A P T E R  2

Using the Log Flag Editor

Use the Log Flag Editor to control the categories of messages that are logged 
on a selected node in the Log Viewer Console Tree. Also, save specific log flag 
settings in a file, which then can be used on another computer to control its 
logged messages. This chapter describes how to do these two main functions.

Note  We recommend that you read Log Flag Editor User Interface to become 
familiar with the terminology used in the following procedures.

Each of the following procedures assumes that the Log Flag Editor and Log 
Viewer are started, and additional ArchestrA components are installed on the 
selected node. To start the Log Flag Editor, click Log Flags on the Action 
menu of the Log Viewer.

Contents
• Controlling Logged Messages

• Enabling Log Flags for a Single Component

• Enabling Log Flags Globally

• Mixed Global/Component Examples

• Using Log Flag Files

• Saving Log Flag Settings

• Opening Log Flag Files

• Determining the Log Flag Editor Version

Controlling Logged Messages
The tri-paned Log Flag Editor user interface provides multiple ways of 
controlling logged messages. You can enable log flags for individual 
ArchestrA components, on a global basis, or a mixture of the two. Also, you 
can use a specific log flag to determine which components use it, and then 
control in which components you want to enable or disable that log flag.
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Enabling Log Flags for a Single Component
To use log flags on a component level

1. In the Component List (left pane), select a component for which you want 
to enable log flags. The Log Flags View (top right pane) displays the log 
flags for the component you selected.

2. In the Log Flags View, select the check box of the log flag you want to 
enable.

3. On the File menu, click Apply. All messages from the selected component 
and associated with the selected log flag are logged.

Enabling Log Flags Globally
To use log flags on a global basis

1. In the Component List (left pane), select Global. The Log Flags View (top 
right pane) displays the log flags for all components installed on the 
selected node.

2. In the Log Flags View, select the check box of the log flag you want to 
enable.

3. On the File menu, click Apply. All messages associated with the selected 
log flag are logged.

Mixed Global/Component Examples
To enable a log flag globally except for a single component

1. In the Component List (left pane), select Global. The Log Flags View (top 
right pane) displays the log flags for all components installed on the 
selected node.

2. In the Log Flags View, select the log flag you want to enable and its check 
box. The Component View (bottom right pane) displays all components 
that use the selected log flag. Each component’s check box is selected.

3. In the Component View, clear the check box of one component. The check 
box for the selected log flag is now colored gray, indicating that at least 
one component that uses this log flag has been disabled.

4. On the File menu, click Apply. All messages associated with the selected 
log flag, except those from the disabled component, are logged.

Note  The Logger continues to log messages associated with all other enabled 
log flags for the component mentioned in step 3.

Another way to produce the same result as the previous precedure

1. In the Component List, select Global. The Log Flags View displays the 
log flags for all components installed on the selected node.
Log Flag Editor User’s Guide



Using the Log Flag Editor 15
2. In the Log Flags View, select the check box of the log flag you want to 
enable.

3. In the Component List, select a component. The Log Flags View displays 
the log flags for the component you selected. The log flag enabled in step 
2 is enabled.

4. In the Log Flags View, clear the check box of the log flag you want to 
disable for the selected component. In the Component List, select Global 
again. The check box for the selected log flag is now colored gray, 
indicating that at least one component that uses this log flag has been 
disabled.

5. On the File menu, click Apply. All messages associated with the selected 
log flag, except those from the disabled component, are logged.

To determine which components use a specific log flag

1. In the Component List, select Global. The Log Flags View displays the 
log flags for all components installed on the selected node.

2. In the Log Flags View, select the name (not the check box) of the log flag 
you want to enable. The Component View displays all components that 
use the selected log flag.

3. In the Component View, select the check box of the component for which 
you want to enable the selected log flag. The check box for the selected 
log flag is now colored gray, indicating that at least one component that 
uses this log flag has been disabled.

4. In the Component List, select Global. Note that the check box for the log 
flag of interest is colored gray.

5. On the File menu, click Apply. All messages from the enabled component 
that are associated with the selected log flag are logged.

Using Log Flag Files
You can save the current log flag settings to a file (.aaLGF extension) for 
several reasons, including:

• Backing up commonly used log flag settings

• Storing special-purpose log flag settings

• Using log flag settings on another computer

Once saved to file, log flag settings can be opened in any Log Flag Editor.

Saving Log Flag Settings
To save log flag settings to file

1. In the Log Flag Editor, set up all components and log flags as desired. 
Note that these settings do not affect which messages are currently being 
logged on the selected node. To do that, you must click Apply on the File 
menu.
Log Flag Editor User’s Guide
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2. On the File menu, click Save As. The Microsoft Save As dialog box is 
displayed.

3. In the Save As dialog box, enter a path and filename for the log flag 
settings file, and click Save. Click Cancel to return to the Log Flag Editor 
without creating a new log flag settings file.

Opening Log Flag Files
To open a log flag settings file

1. On the File menu, click Open. The Microsoft Open dialog box is 
displayed.

2. In the Open dialog box, explore for the log flag settings file (.aaLGF 
extension), and click Open.

Note  The new settings take immediate effect only in the Log Flag Editor 
user interface. You then can apply them, edit and apply them, or edit and 
save them to file again. To affect messages being logged to the Logger of 
the selected node, you must click Apply on the File menu.

In the Open dialog box, click Cancel to return to the Log Flag Editor and 
the previous log flag settings.

Note  You also can open a log flag settings file by right-clicking it from 
Windows Explorer and clicking Edit on the shortcut menu. Also, you can 
apply new log flag settings from a file to the selected node by double-clicking 
it from Windows Explorer. You are prompted to confirm the changes before 
they take effect.

Determining the Log Flag Editor Version
To determine the version of your Log Flag Editor

1. On the Help menu, click About Log Flag Editor.

2. After viewing the information on the About Log Flag Editor dialog box, 
click OK.
Log Flag Editor User’s Guide
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C H A P T E R  3

Log Flag Editor User Interface

The Log Flag Editor is a tool you can use to manage the messages logged in a 
local or remote Logger. Start the program by clicking Log Flags on the Log 
Viewer’s Action menu. This chapter describes the Log Flag Editor user 
interface.

Contents
• Main Window

• Menu Bar

• Toolbar

• Component List

• Log Flags View

• Component View

• Shortcut Menus

• About Box

Main Window
The Log Flag Editor consists of a single main window with standard Microsoft 
window elements like a title bar, menu bar, toolbar buttons and status bar, as 
well as a tri-paned work area consisting of Component List, Log Flags View 
and Component View.
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Menu Bar
The Log Flag Editor has three menus: File, View, and Help.

The File menu is comprised of the following commands:

• Apply: use to apply the current log flag settings to the messages being 
logged on the selected node.

• New: use to restore the last applied log flag settings to the user interface. 
Use this command to close a log flag settings file that is currently open. If 
you made unsaved changes to the log flag settings contained in the file, 
you are prompted to save them before it is closed.
Log Flag Editor User’s Guide
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• Open: use to open a log flag settings file (.aaLGF extension).

• Save: use to save currently displayed log flag settings to the .aaLGF file 
you have open. The filename of the open log flag settings file should be 
displayed in the title bar. If the title bar instead displays a node name, a log 
flag settings file is not open and this command is unavailable.

• Save As: use to save the current settings to a new .aaLGF file.

• <Recent File List>: use to open a recently-used log flag settings file 
(.aaLGF extension). Click a filename in the Recent File list. The user 
interface immediately reflects the file’s log flag settings and the filename 
is displayed in the title bar. If you have not saved log flag settings to a file 
recently, this command is unavailable.

• Exit: use to quit the Log Flag Editor utility.

The View menu is comprised of the following commands:

• Toolbar: use to display or hide the toolbar. When this command is 
checked, the toolbar is displayed.

• Status Bar: use to display or hide the status bar. When this command is 
checked, the status bar is displayed.

The Help menu is comprised of the following commands:

• Help Topics: use to open the Log Flag Editor’s online help.

• About Log Flag Editor: use to display the About box for this utility, 
which provides version and copyright information.

Toolbar
The Log Flag Editor toolbar consists of icons for quick access to frequently 
used commands on the menu bar. The tooltip associated with each icon is 
based on the text displayed when you point to it. See Menu Bar earlier in this 
chapter for descriptions of these commands.

Icon Tooltip

New

Open

Save

Apply

Help
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Component List
The left pane of the main window is the Component List. This view shows all 
components available for configuration. The root of the hierarchy is the 
selected node (see Remote Nodes and the Main Window for more 
information). The Global option represents all log flags in all components 
listed in the Component List.

Note  The components shown in this view correspond to the items displayed 
in the Component column of the Log Viewer.

Select a component in this view and all log flags associated with messages 
provided by that component are displayed in the Log Flags View pane. Select 
Global and all log flags associated with all messages are displayed.

Log Flags View
The top right pane of the main window is the Log Flags View. This view shows 
all log flags associated with the option selected in the Component List. The 
title of this view displays the option you select in the Component List.

Note  The log flags shown in this view correspond to the items displayed in 
the Log Flag column of the Log Viewer.

A log flag that is selected (check box is checked) indicates messages 
associated with that log flag are to be logged.

The Log Flags View displays default log flags first (displayed in black text), 
followed by custom log flags in alphanumeric order (displayed in blue text). 
The Log Flags View and Component View dynamically interact depending on 
your selections. For instance:

• Select a log flag (just the log flag name) and all components with 
messages associated with that log flag are displayed in the Component 
View.

• Select a log flag’s check box and the check boxes of all components in the 
Component View are enabled. Clear the log flag’s check box and the 
check boxes of the components are cleared.

• Select a log flag’s check box and the check boxes of all components in the 
Component View are enabled. Clear one component’s check box and the 
log flag’s check box is colored gray, indicating that at least one component 
that uses this log flag has been disabled.

Component View
The bottom right pane of the main window is the Component View. This view 
shows all components with messages associated with the log flag selected in 
the Log Flags View. This view allows you to select only those components that 
you want to log messages of the log flag type selected.

See Controlling Logged Messages in the Using the Log Flag Editor chapter for 
more examples of how to use the Log Flag Editor.
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Shortcut Menus
The Log Flag Editor provides two shortcut menus, one in the Component List 
and another in the Log Flags View.

The Component List shortcut menu is comprised of the following commands:

• Add Component: use to add a new component to the list. The new 
component is displayed initially in rename mode. Right-click anywhere in 
the Component List to display this command.

Note  You cannot use this command simply to create a functioning 
component. The Log Flag Editor updates the Component List when you 
install new ArchestrA components on the selected node (you must restart 
the Log Flag Editor after installation of the component). You could use 
this command to add a component that exists on another computer, save 
the log flag settings to file and then use the file to control messages on that 
other computer (if you could not do so remotely). See Using Log Flag 
Files in the Using the Log Flag Editor chapter for more information about 
sharing log flag settings between computers.

• Remove Component: use to delete a component from the list. You are 
prompted to confirm the deletion before the component is removed. Right-
click anywhere in the Component List to display this command, although 
it is unavailable for Local or Global selections.

Note  If you remove a component from the list that exists on your 
computer, it will reappear in the list when you restart the Logger and Log 
Flag Editor. Typically, you would use this command to clean up the 
Component List after you uninstall a component.

The Log Flags View shortcut menu is comprised of the following commands:

• All Flags ON: use to enable all log flags shown in this view for the 
component selected in the Component List. Right-click anywhere in the 
Log Flags View to display this command.

• All Flags OFF: use to disable all log flags shown in this view for the 
component selected in the Component List. Right-click anywhere in the 
Log Flags View to display this command.

• Add Custom Flag: use to create a new custom log flag. The new log flag 
is displayed in rename mode. Right-click anywhere in the Log Flags View 
to display this command.

Note  You cannot use this command simply to create a functioning log 
flag. The Log Flag Editor updates the available log flags for each 
component when you install new ArchestrA components on the selected 
node (you must restart the Log Flag Editor after installation of the 
component). You could use this command to add a custom flag that exists 
on another computer, save the log flag settings to file and then use the file 
to control messages on that other computer (if you could not do so 
remotely). See Using Log Flag Files in the Using the Log Flag Editor 
chapter for more information about sharing log flag settings between 
computers.
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• Remove Custom Flag: use to remove a custom log flag from this view. 
Right-click on the specific log flag to activate this menu item. You are 
prompted to confirm the deletion before the log flag is removed. Right-
click on any custom flag in the Log Flags View to display this command. 
If none exists, this command is unavailable.

Note  If you remove a custom log flag that exists on the selected node, it 
will reappear in the list when you restart the Logger and Log Flag Editor.

Remote Nodes and the Main Window
The Log Flag Editor displays in its title bar, status bar, and at the top of its tree 
view root the name of the node selected in the Log Viewer Console Tree. If the 
node is the local computer, "(Local)" is appended to the node name. Also, all 
messages that may be displayed contain the node name.

The components and log flags displayed in the Log Flag Editor reflects those 
of the selected node. The one exception is when you have opened a log flag 
settings file (.aaLGF extension), in which case, the components and log flags 
reflects those in the file.

When using the Log Flag Editor to edit a log flag settings file, the name of the 
file is displayed in the tree view root. The title bar and status bar continue to 
display the node to which you are currently connected. You can apply the file’s 
settings to the selected node or click the New command on the File menu to 
return to the selected node’s active configuration.

About Box
The About dialog box box provides version, copyright and other information 
about the Log Flag Editor. Open this dialog box by clicking About Log Flag 
Editor on the Help menu. The following image is shown as an example.
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